Welcome, Guest
Username Password: Remember me

WIFI fails to connect automatically
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: WIFI fails to connect automatically

WIFI fails to connect automatically 5 years, 1 month ago #172

Reeti is not auto connecting to our wireless network. We have to wait for this to fail, and then manually connect. I think that the SSID or password may be incorrect in the config. Where can I find these settings?

Re: WIFI fails to connect automatically 5 years, 1 month ago #173

Hi,

On the home page of Reeti interface you can use the wiFi menu (icon on top of screen).

Otherwise wiFi configuration is recorded in /reetiPrograms/data/Wifi/wifi.conf

Regards.

Re: WIFI fails to connect automatically 5 years, 1 month ago #174

That is interesting. I do not have a Wifi folder under data, or anywhere for that matter. I seem to not have the config file for Wifi at all.

Not sure why I don't have it. Can you share what that file should contain so I can create it.

Thanks,

Re: WIFI fails to connect automatically 5 years, 1 month ago #175

Try to connect to your wiFi network through the Reeti interface Icon (radio Icon on the top of the interface).
It should create configuration files.

Re: WIFI fails to connect automatically 5 years, 1 month ago #176

We have done that numerous times, but that file never gets created. Perhaps this is a permissions issue or something?

Re: WIFI fails to connect automatically 5 years, 1 month ago #177

Hi,

I will explain here, how to re-enable the native network manager of ubuntu and disable the Reeti network manager.
1. Re-enable the native network manager :
The two following command lines must be typed as "sudo" :

 
sudo mv /etc/init/network-manager.conf.DISABLE /etc/init/network-manager.conf
sudo mv /etc/xdg/autostart/nm-applet.desktop.DISABLE /etc/xdg/autostart/nm-applet.desktop
 


2. Disable the Reeti network
As "sudo" user open the following file for edition :
/reetiPrograms/load/InitModule.u

Somewhere around the line 127, you must found the following code :
 
if(isUConnectLoaded==false)
{
loadModule("/reetiPrograms/UModules/libUConnect");
var Global.uconnect = uobjects.UConnect.new(IP, portUrbi);
isUConnectLoaded=true;
};
 


You must comment the 3 lines inside the if block with "//", so the lines will become :
 
if(isUConnectLoaded==false)
{
//loadModule("/reetiPrograms/UModules/libUConnect");
//var Global.uconnect = uobjects.UConnect.new(IP, portUrbi);
//isUConnectLoaded=true;
};
 


Restart your reeti.

When you reeti has restarted, you can find in the ubuntu menu bar the default network manager. Here you can configure your Favorite WiFi like with all ubuntu systems.
When you WiFi is configured, restart you reeti, and the reeti will automatically connect to the configured WiFi network. In the reeti main screen, the WiFi Management Icons still exists, but they are useless (because we have commented the lines in InitModule.u).

Reeti was not designed to be used like this, so mayebe we can encounter some side effects. The reverse procedure will allow to set the reeti with the "factory" settings.

Regards,

A. BARRAL
  • Page:
  • 1
Time to create page: 0.32 seconds