Welcome, Guest
Username Password: Remember me

Issues installing standard packages
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: Issues installing standard packages

Issues installing standard packages 9 years ago #4


Hi,

I struggled a bit to install some standard ubuntu packages (git for example). In the end I managed to get it to work, but I may also have broken stuff. Anyway here is my log for this:

1. replace /etc/apt/sources.list by /etc/apt/sources.list.repoUbuntu
2. Run a sudo apt-get update
3. Run a sudo apt-get install git, I get the following error:


You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
git : Depends: liberror-perl but it is not going to be installed
Depends: git-man (> 1:1.7.5.4) but it is not going to be installed
Depends: git-man (< 1:1.7.5.4-.) but it is not going to be installed
ros-electric-vision-opencv : Depends: libopencv2.3-dev (= 2.3.1+svn6514+branch23-12~oneiric) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


4. Try sudo apt-get -f install:

The following extra packages will be installed:
libopencv2.3 libopencv2.3-bin libopencv2.3-dev
The following NEW packages will be installed:
libopencv2.3 libopencv2.3-bin libopencv2.3-dev

Question? Am I gonna break standard opencv for Reeti?
Moving on and accepting the changes I get this error:


Unpacking libopencv2.3 (from .../libopencv2.3_2.3.1+svn6514+branch23-12~oneiric_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libopencv2.3_2.3.1+svn6514+branch23-12~oneiric_i386.deb (--unpack):
trying to overwrite '/usr/lib/libopencv_calib3d.so.2.3.1', which is also in package opencv 2.3.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking libopencv2.3-bin (from .../libopencv2.3-bin_2.3.1+svn6514+branch23-12~oneiric_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libopencv2.3-bin_2.3.1+svn6514+branch23-12~oneiric_i386.deb (--unpack):
trying to overwrite '/usr/bin/opencv_createsamples', which is also in package opencv 2.3.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking libopencv2.3-dev (from .../libopencv2.3-dev_2.3.1+svn6514+branch23-12~oneiric_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libopencv2.3-dev_2.3.1+svn6514+branch23-12~oneiric_i386.deb (--unpack):
trying to overwrite '/usr/lib/libopencv_video.so', which is also in package opencv 2.3.1
Errors were encountered while processing:
/var/cache/apt/archives/libopencv2.3_2.3.1+svn6514+branch23-12~oneiric_i386.deb
/var/cache/apt/archives/libopencv2.3-bin_2.3.1+svn6514+branch23-12~oneiric_i386.deb
/var/cache/apt/archives/libopencv2.3-dev_2.3.1+svn6514+branch23-12~oneiric_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


5. Remove open cv packages: sudo dpkg -r opencv

6. Retry sudo apt-get -f install,works fine, can now do proper apt-get install

Re: Issues installing standard packages 9 years ago #5

We installed git before ROS so we did not have the same problem.
Anyway you won't have any trouble with existing Reeti Modules.
Let us know if you have troubles with your ROS modules development using openCV.

Re: Issues installing standard packages 9 years ago #16

Quick follow-up. I upgraded Ubuntu to 12.04 (in order to have the latest unstable openni libraries etc...), so far everything is working fine, I didn't try much of OpenCV so I can't tell if I've broken anything yet.
  • Page:
  • 1
Time to create page: 0.14 seconds