Welcome, Guest
Username Password: Remember me

Reeti's not responding!
(1 viewing) (1) Guest

TOPIC: Reeti's not responding!

Re: Reeti's not responding! 4 years, 11 months ago #187

I am having the same issue. Reeti all of a sudden just stopped working. I can no longer get him to move or play an audio file. I tried to unplug and wait 90 sec, but that does not work.

Here are the results of lsusb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 003 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 003 Device 003: ID 413c:3012 Dell Computer Corp. Optical Wheel Mouse
Bus 005 Device 002: ID 0b05:179c ASUSTek Computer, Inc.
Bus 001 Device 006: ID 04d8:0204 Microchip Technology, Inc.
Bus 001 Device 007: ID 045e:076d Microsoft Corp. LifeCam HD-5000
Bus 001 Device 008: ID 045e:076d Microsoft Corp. LifeCam HD-5000

From this can you tell if our USB is dead or not?

We are in the middle of our research project, so I am willing to perform the maintenance if that is faster.

Thanks,

Andy

Re: Reeti's not responding! 4 years, 11 months ago #189

According to the lsusb output, everything is OK about USB.
The Reeti head is the 'Microchip' line.

Could you try again to unplug Reeti for 90 sec (you have to unplug the jack under Reeti) ?

When you plug it again, you need to plug it straightly. Sometimes if you plug it too slowly, in fact you plug it for a few microseconds then unplugit a few miroseconds and finaly plug it. This gives the same result about power voltage problem explained before.

Tell me if this does not solve the problem.

Re: Reeti's not responding! 4 years, 11 months ago #190

I tried unplugging again and it did not help.

I started to poke around a bit more and saw an issue in .xsession-errors :

....[00003905:error] !!! /reetiPrograms/load/InitVar.u:72.14-65: new: Value too large for defined data type: /reetiPrograms/logs/errors.log

Turns out that my errors.log was 2.4 GB. I renamed it, restarted, and everything started properly.

Looking at the errors.log file, it was filled with thousands of rows of these two lines:

Tue Dec 30 12:09:28 2014Error 2.1. ReetiHead Error: Unable to read on USB port
Tue Dec 30 12:09:28 2014Error 2.1. Servo Error: Unable to write on USB port

Now that Reeti is working again, we can continue with the research, but I would like to know if there is any way to prevent the error above.

Thanks,

Andy

Re: Reeti's not responding! 4 years, 11 months ago #191

Hi,

We already know that this error is logged in the starting phase and that it should be modified (but it wasn't a priority until now)
That is the first time it causes a crash.
So I open an issue to upgrade the Reeti Head module in order it does not log this error anymore during the starting phase. We will put it on Reeti repository as soon as possible.
Time to create page: 0.16 seconds