Welcome, Guest
Username Password: Remember me

Update refused as "untrusted package"
(1 viewing) (1) Guest
  • Page:
  • 1
  • 2

TOPIC: Update refused as "untrusted package"

Update refused as "untrusted package" 5 years, 7 months ago #182

Hello Reeti team,

when I tried installing the TTS update on our Reetis, the update manager refused to download them with this error message:
Requires installation of untrusted packages
The action would require the installation of packages from not authenticated sources.

This keeps happening on at least three Reetis.

In the software sources settings, I see four "RUpdate" sources and one ROS source listed on the "Other Software" tab, which looks okay to me.
However, the "Authentication" tab only shows three Ubuntu keys and one for ROS, but nothing Reeti-specific.

Is there a key I need to import? Where would I find that key?
Or is there a different explanation?

Kind regards,
Kathrin

Re: Update refused as "untrusted package" 5 years, 7 months ago #183

Hi Kathrin,

We never had this problem, and it shouldn't be necessary to add any key.
I cannot find any explanation right now. I will do some tests here with our Reeti.

Do you use the Reeti update Manager (update icon on top of Launcher interface) or an Ubuntu update Manager ?

Re: Update refused as "untrusted package" 5 years, 7 months ago #184

First I tried the update manager in the launcher.
It was empty at first. After clicking on "Check for Updates" it was searching for a while, but the list stayed empty after that.

However, when I click on "Select ALL", the Ubuntu update manager opens in the background and shows the available packages. Is it meant to do that?


If I click on "Valid" on the launcher's update window, the launcher becomes busy like it was processing something (showing a clock cursor). It stays that way, apparently forever. But according to our router there is almost no internet traffic during that time (only a few KB per second), so I'm not sure whether it is actually trying to download anything or just stuck in a loop.

If I switch to Ubuntu's update manager instead, I can start the update from there, but after a few seconds the update aborts with the error message I quoted above.

There was also a ROS update (python-rospkg) which could be downloaded without any authentication problems. But then it failed to install because of a Python dependency - I doubt that that is related, but who knows...

I think I also tried running "sudo apt-get" at some point, but that was on monday evening so don't remember that clearly.



If it helps, I can give you details about our internet connection.

In general, all computers in our labs need to use a static IP address, subnet mask etc. because only members of the university are allowed to access the internet.

Two of the Reetis access the internet through a WiFi router that has such a static IP address. Their connection to the router was set up without the Launcher's network manager (according to the instructions in this post) because it refused to connect to the WiFi.

The third Reeti is in a different room and as far as I know, it accesses the university's network directly over an ethernet cable, also with static IP address for this connection. I can check that tomorrow when I meet with the student who is working on that Reeti.


Are there any other settings or configurations that I should check?

Re: Update refused as "untrusted package" 5 years, 7 months ago #185

Hi,

We did not find any explanation right now. We will keep you informed as soon as we find it.

For the short term, I send you the updated debian packages and you can install them with command "dpkg -i xxxx.deb"

Re: Update refused as "untrusted package" 5 years, 7 months ago #186

Hi Christophe,

thank you for the debian packages, I have installed them on two of the Reetis and had no problems with that.

We have started to work with the new TTS on those Reetis. I'll wait with updating the others so that we can still test possible solutions to the update problem.

Re: Update refused as "untrusted package" 5 years, 6 months ago #192

The error message "Update refused as "Untrusted Package"" is normal with synaptic, or ubuntu update manager, because we don't install GPG keys in the Reet V1 repository (this will be fixed on the reeti V2).

It is possible to do the update in console mode thanks to the following command :

 
sudo apt-get -u upgrade
 


This will list all the upgradable packages. For the reeti packages, apt-get will generate a warning which say : " You will install untrusted package, are you sure ?". Just answer "Yes" to this question, and the upgrade process will complete successfully.

If you want to test it, I did a fake upgrade of RTetris. So you can try to run this command line on your reeti, and RTetris must be upgraded.
  • Page:
  • 1
  • 2
Time to create page: 0.22 seconds